Lion Server

Post Reply
Guest

Lion Server

Post by Guest » Wed Jan 04, 2012 8:16 am

WebDAV on my Lion server is not working, and everything I do to fix it fails.

 

The System:

Brand new Mac mini, 2.5GHz i5, purchased less than a week ago.

No 3rd party software installed at all.

Purchased and installed Lion Server as soon as initial system setup was done.

 

My Setup:

In Server.app I have Web, Wiki, and File Sharing turned on.

I made two shares available under File Sharing: the Public share that already existed, and Media (which I created).

Both shares have the "Share with iOS devices" option enabled.

I have two user accounts for testing; one is an admin, the other is a regular user.  Both are part of the staff group.

 

The Result:

Apps such as ezShare Pro fail to connect with Server Error type messages.

Pages on the iPad and iPhone both return an error "An error occured. Please try again."

Attempting to load the WebDAV URL in Safari yields a "You don't have permission to access /webdav/ on this server." after requesting credentials.

Using "Connect to Server" in Lion generates an error "There was a problem connecting to the server 'xxx'".

 

 

The worst thing about this was that I took several hours and did a full restore of Lion, just in case I managed to get something wrong.  That unfortunately has not helped.  I find it really hard to believe that this software passed the final QC before it was released.  Not sure where to turn at this point, my only options ourside of here are Apple Care/Store or just return everything and resurrect a windows box.

 

Any suggestions would be welcome.


Guest

Re:Lion Server

Post by Guest » Wed Jan 04, 2012 9:00 am

Me too. Any solutions?

Guest

Re:Lion Server

Post by Guest » Wed Jan 04, 2012 9:55 am

I have the exact same problem.

Guest

Re:Lion Server

Post by Guest » Wed Jan 04, 2012 10:21 am

So to follow up, I did a full restore on the mini again last night, and no I have a new problem.  When I try to active APNS it sits on "Acquiring" forever.  I left it that way last night before bed, and when I woke up this AM it was still on that window.  Rebooted the mini and tried again, still hanging after 15 minutes.

 

Is this what I can expect from Lion Server?  Seriously, I'm running into more bugs that on any Windows Server I have ever deployed.


Guest

Re:Lion Server

Post by Guest » Wed Jan 04, 2012 10:48 am

Webdav access is not thru Safari.

 

Check out this discussion:  https://discussions.apple.com/thread/3257447?start=0&tstart=0  and see if that helps you.

 

The user that you're trying to access the share with has permission to access the folder on the server right?  If you go in Finder and then Get Info on the folder you want them to access, they should have access to it.

 

Web is running and you have access to it correct?

 

Sometimes restarting the Web via Server app helps.

 

See if you can see the shares you want in /etc/apache2/webdav_sharepoints.plist 

 

Very poor documentation for all of this


Post Reply